FAQ

Problems and questions which can occur when installing mXDriver for Macs with AMD Graphics were sometimes already experienced by other users. Therefor we like to collect some of these questions and possible solutions here. As mXDriver is being constantly developed it could happen that some problems listed here are not valid for newer version of mXDriver but for history reasons and because some people might like to use older versions of mXDriver we keep them listed.

Installation of mXDriver is pretty easy and comes very close to the ease of installing AMD’s Radeon Crimson driver although if you run into problems it will be could to have some technical knowledge of PCs (hardware and software). For installation instructions please see the Howto section. If you have any more questions please let us know by comment or email.

Questions

Answers

  • You can easily fix this by running the repair feature of your the included MSI under \Packages\Apps\CN\CNext\cnext64\ccc-next64.msi
  • If you have a Crossfire system turn off Crossfire mode and see if this helps.
  • 1. Open Registry Editor (regedit.exe)
    2. Go to HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\0000
    3. Find KMD_EnableBrightnessInterface2
    4. Set it to 0
    5. Reboot your machine
    6. In Device Manager, disable your video adapter and re-enable it
    Now brightness settings should work as usual.
  • No. If you turn off testsigning mode Windows will unload mXDriver.
  • If you have troubles running a Vulkan application, which ran with mXDriver 16.9.1 Reloaded (Vulkan API 1.0.21), than it should be sufficient if you replace amdvlk64.dll in C:\Windows\System32 with this older version. Newer versions of mXDriver come with updated versions of amdvlk64.dll, to get version 1.0.21 of amdvlk64.dll you can just use the file from mXDriver 16.9.1 Reloaded. The file is located in the ZIP-Archive under Packages/Drivers/Display/WT6A_INF/B******/ (the * are placeholders for a sequence of numbers which change with every release).
  • Go to Radeon Settings and disable Crossfire Mode, this could help. You find the option to disable it in the Radeon Settings under Gaming tab –> Global Settings.
  • It seems like there is an issue with AMD’s driver for the Radeon R9 M390 which also affects the official Boot Camp driver released by Apple/AMD!
    On Windows 7 systems M390 seem to work but on newer operating systems (Windows 8, Windows 8.1 and Windows 10) users get “Code 43” errors with the official Boot Camp driver, too. Because of this mXDriver cannot deliver support for the Radeon R9 M390 GPU in Apple iMacs as long as these issues aren’t fixed by AMD or Apple.For further information please see this post in Apple’s forums: https://discussions.apple.com/thread/6673968
  • For OpenCL to work you need to install the AMD APP SDK which you can find here.

8 comments on “FAQ

  1. Hi There, thank you very much for your work! I have a few minor issues I’m wondering if you can help shed some light.

    First of all, I have tried the two different installation methods and both result in the same.
    Basically the drivers work and GTA Online looks at least twice as good and runs way smoother than it did with the bootcamp drivers.

    My only issue is now when I restart in OSX I get an error message. It takes a long time for windows to actually shut down and restart and then OSX seems to freak out. Screen goes black for a while and then I get a few error messages saying the computer had problems restarting or something. Then it asks if I want to re-open the program and my display seems to be cut into two segments. If I click ok, then the screen merges into one again and everything seems fine.

    It mostly an annoyance, but I’m wondering if you have heard or seen this happen and is there anything I can do to fix it.

    Thanks again!!

  2. after update the MXDriver 17.5.1
    when I start Rinbow 6(a game)
    it tell me that my Graphic card does not support DX11
    (it is macbook pro 15 , M370X)

    • Hi, thanks for the information. It was because I migrated the website to a new server. It should work flawlessly now.

  3. Hello , I need help.
    iMac 2015 Later M395
    DUU to unintalled success
    Start the installation failed. Error 173.Cant found the driver.
    Help please.
    Thank you.

Leave a Reply

Your email address will not be published. Required fields are marked *