mXDriver 17.1.1 out

mXDriver 17.1.1 is based on AMD’s Radeon Software Crimson ReLive Edition 17.1.1  and brings the usual optimizations from AMD (newly supported games and bugfixes) as well as support for Resident Evil 7. Vulkan support is also included and gives Doom a big fps boost. Please note: Newer versions of the Vulkan API (1.0.26+) don’t work with the Vulkan Stardust Demo although other applications like Doom work great in Vulkan mode.

If you have troubles running a Vulkan application, which ran with mXDriver 16.9.1 Reloaded (Vulkan API 1.0.21), than it should be sufficient if you replace amdvlk64.dll in C:\Windows\System32 with an older version. mXDriver 17.1.1 comes with a newer version of amdvlk64.dll, to get version 1.0.21 of amdvlk64.dll you can just use the file from mXDriver 16.9.1 Reloaded. The file is located in the ZIP-Archive under Packages/Drivers/Display/WT6A_INF/B******/ (the * are placeholders for a sequence numbers which change with every release). If this advice does not help you please let me know in the comments section.

For a more detailed look into the changes of 17.1.1 please see the changelog.

KEEP IN MIND INSTALLING AND USING THE DRIVER IS AT YOUR OWN RISK! I AM NOT RESPONSIBLE FOR ANY DAMAGES! PLEASE BACKUP YOUR STUFF PRIOR INSTALLING THE DRIVER!
For prerequisities and installation details please see the mXDriver Howto.

Download: mXDriver-17.1.1-64Bit-Win10

SHA1 Checksum: f50c41e380824b1f80216b2e85969f6e6abeaccb

Supported GPUs

Mac Pro
D300, D500, D700
iMac
M290, M290X, M295X, M380, M390X, M395, M395X
MacBook Pro
M370X

8 comments on “mXDriver 17.1.1 out

  1. Works great for COD Infinity Warfare. Mac Pro (2013) w/ AMD D300’s. No tears/low FPS like in 16.12.2. Many thanks, Joe!

  2. Great driver! Just wondering if someone can help me with a small problem: VCE (GPU encoding) is no longer working for me ever since I reformatted. I’m using this driver which is perfectly stable and I’ve used other drivers (16.xx) from here. I’ve checked and done all the things I can think of: revert drivers (including Mac Default), check visual studio versions, try various programs (OBS, ReLive, PlaysTv), downloaded AMD SDK, disable xbox dvr. Do you have any ideas what else I should try?

    • Hi Andrew, I don’t have any experiences with VCE, sorry. Did you try the “old” driver which worked prior reinstallation? Is it working with this driver after reinstallation?

      • I did, I also reverted back to drivers that I used before the format. No luck on VCE. I might do another format, start with default Mac drivers and work from there. I feel like it’s not related to drivers, something else must be wrong. Very weird since the Mxdrivers have been flawless for me (Mac Pro, D500s)

        • From what you’re writing I also think it’s not driver related. Might be a missing software or just a different configuration.

  3. my graphic card has newly modded vbios, i unlocked the 896 shader to 1024 shader for RX 460 4gb sapphire nitro. and when i update the driver to latest, the amd download manager keeps on not responding. i always stuck in old driver version 16.6 crimson. pls help me with this. how can i update this to new driver? thanks in andvance!

Leave a Reply

Your email address will not be published. Required fields are marked *